Back to overview
Resolved
Platform Backend and API are down
Jul 5, 2026 at 3:57pm UTC
Affected services
API
Platform Backend
Resolved
Jul 5, 2026 at 4:04pm UTC
We have identified and fixed the issue.
Affected services
Created
Jul 5, 2026 at 3:57pm UTC
We are currently investigating the issue.
Affected services